Runs Failing with "Self-hosted agent pool assignment is required by policy."

Incident Report for scalr.io

Postmortem

Root cause
A regression in a release deployed the morning of 2026-08-25 caused the run policy engine to incorrectly flag self-hosted agent pool assignments as non-compliant, triggering the error above even for correctly configured workspaces.

Resolution
The release was rolled back, restoring normal behavior. No customer action is required.

Preventive measures
We are adding regression test coverage for this specific scenario (self-hosted agent enforcement combined with valid pool assignment) to prevent recurrence, and reviewing our release validation process for this code path.
We apologize for the disruption this caused to your pipelines.

Posted Aug 25, 2026 - 19:09 UTC

Resolved

This incident has been resolved.
Posted Aug 25, 2026 - 13:31 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 25, 2026 - 13:11 UTC

Identified

Customers who force agent pool assignment on workspaces are seeing the error "Self-hosted agent pool assignment is required by policy." even when an agent is assigned. We are rolling back the code that caused this issue now.
Posted Aug 25, 2026 - 12:23 UTC
This incident affected: Scalr Platform.